import Foundation
let pattern = #"^((?:(?!\.)[\w\/])*?)\/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
/someScript
/module/employee/anotherScript
/someScript/
/module/employee/anotherScript/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.cfm"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)