use strict;
my $str = '/someScript
/module/employee/anotherScript
/someScript/
/module/employee/anotherScript/';
my $regex = qr/^((?:(?!\.)[\w\/])*?)\/?$/imp;
my $subst = '$1.cfm';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";