$re = '/^((?:(?!\.)[\w\/])*?)\/?$/im';
$str = '/someScript
/module/employee/anotherScript
/someScript/
/module/employee/anotherScript/';
$subst = "$1.cfm";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;