using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Bon(.+?)r";
string substitution = @"\n# $&:\n\t";
string input = @"BonjourBonjour";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}