// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Bon(.+?)r").unwrap();
let string = "BonjourBonjour";
let substitution = "\\n# $&:\\n\\t";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}