$re = '/Bon(.+?)r/';
$str = 'BonjourBonjour';
$subst = "\n# $&:\n\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;