using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b";
string substitution = @"";
string input = @"M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}