import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a-zA-Z]{1,2}\\d{3,5}[a-zA-Z]?\\b";
final String string = "M394\n"
+ ",MP4245)\n"
+ "TD493!\n"
+ "X4958A\n"
+ "V49534@\n"
+ "U394U\n"
+ "A5909.\n\n"
+ "TED492\n"
+ "R32\n"
+ "R4!3\n"
+ "U394UU\n"
+ "A5909AA\n"
+ "5349A";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}