const regex = new RegExp('\\b[a-zA-Z]{1,2}\\d{3,5}[a-zA-Z]?\\b', 'gm')
const str = `M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);