re = /\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b/m
str = 'M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result