import re
regex = re.compile(r"\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b", flags=re.MULTILINE)
test_str = ("M394\n"
",MP4245)\n"
"TD493!\n"
"X4958A\n"
"V49534@\n"
"U394U\n"
"A5909.\n\n"
"TED492\n"
"R32\n"
"R4!3\n"
"U394UU\n"
"A5909AA\n"
"5349A")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)