# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(className|class)="(?:block|block\s([^"]*)|([^"]*)\sblock|([^"]*)\sblock(?=\s)([^"]*))"/\1="\2\3\4\5"/gi;t' <<< "class=\"block underline primary blockOverlay\"
class=\"name block\"
class=\"block name\"
className=\"text-center block primary-dark blockout__form\"
class=\"grey bg-black inline-block block blocktitle blockouts-intro\"
class=\"grey bg-black inline-block block-title blockouts-intro\"
class=\"grey bg-black inline-block block title-block blockouts-intro\"
class=\"block\""