using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(className|class)=""(?:block|block\s([^""]*)|([^""]*)\sblock|([^""]*)\sblock(?=\s)([^""]*))""";
string substitution = @"\1=""\2\3\4\5""";
string input = @"class=""block underline primary blockOverlay""
class=""name block""
class=""block name""
className=""text-center block primary-dark blockout__form""
class=""grey bg-black inline-block block blocktitle blockouts-intro""
class=""grey bg-black inline-block block-title blockouts-intro""
class=""grey bg-black inline-block block title-block blockouts-intro""
class=""block""";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}