import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(className|class)=\"(?:block|block\\s([^\"]*)|([^\"]*)\\sblock|([^\"]*)\\sblock(?=\\s)([^\"]*))\"";
final String string = "class=\"block underline primary blockOverlay\"\n\n"
+ "class=\"name block\"\n\n"
+ "class=\"block name\"\n\n"
+ "className=\"text-center block primary-dark blockout__form\"\n\n"
+ "class=\"grey bg-black inline-block block blocktitle blockouts-intro\"\n\n"
+ "class=\"grey bg-black inline-block block-title blockouts-intro\"\n\n"
+ "class=\"grey bg-black inline-block block title-block blockouts-intro\"\n\n"
+ "class=\"block\"";
final String subst = "\\1=\"\\2\\3\\4\\5\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}