# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(className|class)=\"(?:block|block\s([^\"]*)|([^\"]*)\sblock|([^\"]*)\sblock(?=\s)([^\"]*))\""
test_str = ("class=\"block underline primary blockOverlay\"\n\n"
"class=\"name block\"\n\n"
"class=\"block name\"\n\n"
"className=\"text-center block primary-dark blockout__form\"\n\n"
"class=\"grey bg-black inline-block block blocktitle blockouts-intro\"\n\n"
"class=\"grey bg-black inline-block block-title blockouts-intro\"\n\n"
"class=\"grey bg-black inline-block block title-block blockouts-intro\"\n\n"
"class=\"block\"")
subst = "\\1=\"\\2\\3\\4\\5\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.