re = /(className|class)="(?:block|block\s([^"]*)|([^"]*)\sblock|([^"]*)\sblock(?=\s)([^"]*))"/i
str = 'class="block underline primary blockOverlay"
class="name block"
class="block name"
className="text-center block primary-dark blockout__form"
class="grey bg-black inline-block block blocktitle blockouts-intro"
class="grey bg-black inline-block block-title blockouts-intro"
class="grey bg-black inline-block block title-block blockouts-intro"
class="block"'
subst = '\\1="\\2\\3\\4\\5"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result