use strict;
my $str = 'class="block underline primary blockOverlay"
class="name block"
class="block name"
className="text-center block primary-dark blockout__form"
class="grey bg-black inline-block block blocktitle blockouts-intro"
class="grey bg-black inline-block block-title blockouts-intro"
class="grey bg-black inline-block block title-block blockouts-intro"
class="block"';
my $regex = qr/(className|class)="(?:block|block\s([^"]*)|([^"]*)\sblock|([^"]*)\sblock(?=\s)([^"]*))"/ip;
my $subst = '\\1="\\2\\3\\4\\5"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";