# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(?=(?:[^"]*"[^"]*")*[^"]*$)/\n/gm;t' <<< "create myclass \"56, 'for the better or worse', 54.781\""