$re = '/\s(?=(?:[^"]*"[^"]*")*[^"]*$)/m';
$str = 'create myclass "56, \'for the better or worse\', 54.781"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;