import re
regex = re.compile(r"\s(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)", flags=re.MULTILINE)
test_str = "create myclass \"56, 'for the better or worse', 54.781\""
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)