re = /\s(?=(?:[^"]*"[^"]*")*[^"]*$)/m
str = 'create myclass "56, \'for the better or worse\', 54.781"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result