using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string substitution = @"\n";
string input = @"create myclass ""56, 'for the better or worse', 54.781""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}