const regex = /\s(?=(?:[^"]*"[^"]*")*[^"]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?=(?:[^"]*"[^"]*")*[^"]*$)', 'gm')
const str = `create myclass "56, 'for the better or worse', 54.781"`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);