using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"require_once . \$doc_root .\.. (\\)""";
string input = @"require_once $doc_root . ""\inc\common.php"";
require_once $doc_root . ""\inc\admin_login.php"";
require_once $doc_root . ""\inc\usps_functions.php"";
require_once $doc_root . '\lib\PDFMerger\PDFMerger.php';";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}