# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
require_once . \$doc_root .\.. (\\)"
"""
test_str = ("require_once $doc_root . \"\\inc\\common.php\";\n"
"require_once $doc_root . \"\\inc\\admin_login.php\";\n"
"require_once $doc_root . \"\\inc\\usps_functions.php\";\n"
"require_once $doc_root . '\\lib\\PDFMerger\\PDFMerger.php';")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.