package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mix)require_once . \$doc_root .\.. (\\)"`)
var str = `require_once $doc_root . "\inc\common.php";
require_once $doc_root . "\inc\admin_login.php";
require_once $doc_root . "\inc\usps_functions.php";
require_once $doc_root . '\lib\PDFMerger\PDFMerger.php';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}