import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "require_once . \\$doc_root .\\.. (\\\\)\"";
final String string = "require_once $doc_root . \"\\inc\\common.php\";\n"
+ "require_once $doc_root . \"\\inc\\admin_login.php\";\n"
+ "require_once $doc_root . \"\\inc\\usps_functions.php\";\n"
+ "require_once $doc_root . '\\lib\\PDFMerger\\PDFMerger.php';";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}