// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mix)require_once . \$doc_root .\.. (\\)""#).unwrap();
let string = "require_once $doc_root . \"\\inc\\common.php\";
require_once $doc_root . \"\\inc\\admin_login.php\";
require_once $doc_root . \"\\inc\\usps_functions.php\";
require_once $doc_root . '\\lib\\PDFMerger\\PDFMerger.php';";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}