$re = '/require_once . \$doc_root .\.. (\\\\)"/mix';
$str = 'require_once $doc_root . "\\inc\\common.php";
require_once $doc_root . "\\inc\\admin_login.php";
require_once $doc_root . "\\inc\\usps_functions.php";
require_once $doc_root . \'\\lib\\PDFMerger\\PDFMerger.php\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);