const regex = /require_once . \$doc_root .\.. (\\)"/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('require_once . \\$doc_root .\\.. (\\\\)"', 'gmi')
const str = `require_once \$doc_root . "\\inc\\common.php";
require_once \$doc_root . "\\inc\\admin_login.php";
require_once \$doc_root . "\\inc\\usps_functions.php";
require_once \$doc_root . '\\lib\\PDFMerger\\PDFMerger.php';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}