# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\s*(\w+)[^<]*?)\s+this-html=['"]([^"']*)['"]([^>]*?)\s*>[\w\W]*?(<\\/\2>)/$1$4>$3$5/gm;t' <<< "<div this-html=\"text goes here!\" class=\"something\">test</div><div this-html=\"another test\">Option is visible on preview/publish</div>"