import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\s*(\\w+)[^<]*?)\\s+this-html=['\"]([^\"']*)['\"]([^>]*?)\\s*>[\\w\\W]*?(<\\/\\2>)";
final String string = "<div this-html=\"text goes here!\" class=\"something\">test</div><div this-html=\"another test\">Option is visible on preview/publish</div>";
final String subst = "$1$4>$3$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}