import Foundation
let pattern = #"(<\s*(\w+)[^<]*?)\s+this-html=['"]([^"']*)['"]([^>]*?)\s*>[\w\W]*?(<\/\2>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<div this-html="text goes here!" class="something">test</div><div this-html="another test">Option is visible on preview/publish</div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$4>$3$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)