using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\s*(\w+)[^<]*?)\s+this-html=['""]([^""']*)['""]([^>]*?)\s*>[\w\W]*?(<\/\2>)";
string substitution = @"$1$4>$3$5";
string input = @"<div this-html=""text goes here!"" class=""something"">test</div><div this-html=""another test"">Option is visible on preview/publish</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}