re = /(<\s*(\w+)[^<]*?)\s+this-html=['"]([^"']*)['"]([^>]*?)\s*>[\w\W]*?(<\/\2>)/m
str = '<div this-html="text goes here!" class="something">test</div><div this-html="another test">Option is visible on preview/publish</div>'
subst = '$1$4>$3$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result