const regex = /(<\s*(\w+)[^<]*?)\s+this-html=['"]([^"']*)['"]([^>]*?)\s*>[\w\W]*?(<\/\2>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\s*(\\w+)[^<]*?)\\s+this-html=[\'"]([^"\']*)[\'"]([^>]*?)\\s*>[\\w\\W]*?(<\\\/\\2>)', 'gm')
const str = `<div this-html="text goes here!" class="something">test</div><div this-html="another test">Option is visible on preview/publish</div>`;
const subst = `$1$4>$3$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);