#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=(_\()|(_n\())[\w", ()%]+(?=\))"
Local $sString = "_("foo") // want "foo"" & @CRLF & _
"_n("bar", "baz", 42); // want "bar", "baz", 42" & @CRLF & _
"_n(domain, "bux", var); // want domain, "bux", var" & @CRLF & _
"_( "one (optional)" ); // want "one optional"" & @CRLF & _
"apples === 0 ? _( "No apples" ) : _n("%1 apple", "%1 apples", apples) // could have on the same line two calls.."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)