const regex = /(?<=(_\()|(_n\())[\w", ()%]+(?=\))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(_\\()|(_n\\())[\\w", ()%]+(?=\\))', 'gmi')
const str = `_("foo") // want "foo"
_n("bar", "baz", 42); // want "bar", "baz", 42
_n(domain, "bux", var); // want domain, "bux", var
_( "one (optional)" ); // want "one optional"
apples === 0 ? _( "No apples" ) : _n("%1 apple", "%1 apples", apples) // could have on the same line two calls..`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);