using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(_\()|(_n\())[\w"", ()%]+(?=\))";
string substitution = @"";
string input = @"_(""foo"") // want ""foo""
_n(""bar"", ""baz"", 42); // want ""bar"", ""baz"", 42
_n(domain, ""bux"", var); // want domain, ""bux"", var
_( ""one (optional)"" ); // want ""one optional""
apples === 0 ? _( ""No apples"" ) : _n(""%1 apple"", ""%1 apples"", apples) // could have on the same line two calls..";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}