import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(_\\()|(_n\\())[\\w\", ()%]+(?=\\))";
final String string = "_(\"foo\") // want \"foo\"\n"
+ "_n(\"bar\", \"baz\", 42); // want \"bar\", \"baz\", 42\n"
+ "_n(domain, \"bux\", var); // want domain, \"bux\", var\n"
+ "_( \"one (optional)\" ); // want \"one optional\"\n"
+ "apples === 0 ? _( \"No apples\" ) : _n(\"%1 apple\", \"%1 apples\", apples) // could have on the same line two calls..";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}