$re = '/(?<=(_\()|(_n\())[\w", ()%]+(?=\))/mi';
$str = '_("foo") // want "foo"
_n("bar", "baz", 42); // want "bar", "baz", 42
_n(domain, "bux", var); // want domain, "bux", var
_( "one (optional)" ); // want "one optional"
apples === 0 ? _( "No apples" ) : _n("%1 apple", "%1 apples", apples) // could have on the same line two calls..';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;