#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<iframe.*?src=\\")([^ ]*?)(\\".*?>)(.*?)(<\/iframe>)"
Local $sString = "hello <iframe width=\"626\" height=\"782\" src=\"https://www.youtube.com/embed/QGug_eltOnE\" frameborder=\"0\" allowfullscreen></iframe> <iframe src=\"https://www.youtube.com/embed/QGug_eltOnE\" frameborder=\"0\" allowfullscreen></iframe> dear"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")