package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<iframe.*?src=\\")([^ ]*?)(\\".*?>)(.*?)(<\/iframe>)`)
var str = `hello <iframe width=\"626\" height=\"782\" src=\"https://www.youtube.com/embed/QGug_eltOnE\" frameborder=\"0\" allowfullscreen></iframe> <iframe src=\"https://www.youtube.com/embed/QGug_eltOnE\" frameborder=\"0\" allowfullscreen></iframe> dear`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}