$re = '/(<iframe.*?src=\\\\")([^ ]*?)(\\\\".*?>)(.*?)(<\/iframe>)/';
$str = 'hello <iframe width=\\"626\\" height=\\"782\\" src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> <iframe src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> dear';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);