import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<iframe.*?src=\\\\\")([^ ]*?)(\\\\\".*?>)(.*?)(<\\/iframe>)";
final String string = "hello <iframe width=\\\"626\\\" height=\\\"782\\\" src=\\\"https://www.youtube.com/embed/QGug_eltOnE\\\" frameborder=\\\"0\\\" allowfullscreen></iframe> <iframe src=\\\"https://www.youtube.com/embed/QGug_eltOnE\\\" frameborder=\\\"0\\\" allowfullscreen></iframe> dear";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}