using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<iframe.*?src=\\"")([^ ]*?)(\\"".*?>)(.*?)(<\/iframe>)";
string input = @"hello <iframe width=\""626\"" height=\""782\"" src=\""https://www.youtube.com/embed/QGug_eltOnE\"" frameborder=\""0\"" allowfullscreen></iframe> <iframe src=\""https://www.youtube.com/embed/QGug_eltOnE\"" frameborder=\""0\"" allowfullscreen></iframe> dear";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}