const regex = new RegExp('(<iframe.*?src=\\\\")([^ ]*?)(\\\\".*?>)(.*?)(<\\/iframe>)', 'g')
const str = `hello <iframe width=\\"626\\" height=\\"782\\" src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> <iframe src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> dear`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}