re = /(<iframe.*?src=\\")([^ ]*?)(\\".*?>)(.*?)(<\/iframe>)/
str = 'hello <iframe width=\\"626\\" height=\\"782\\" src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> <iframe src=\\"https://www.youtube.com/embed/QGug_eltOnE\\" frameborder=\\"0\\" allowfullscreen></iframe> dear'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end