// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<iframe.*?src=\\")([^ ]*?)(\\".*?>)(.*?)(<\/iframe>)"#).unwrap();
let string = "hello <iframe width=\\\"626\\\" height=\\\"782\\\" src=\\\"https://www.youtube.com/embed/QGug_eltOnE\\\" frameborder=\\\"0\\\" allowfullscreen></iframe> <iframe src=\\\"https://www.youtube.com/embed/QGug_eltOnE\\\" frameborder=\\\"0\\\" allowfullscreen></iframe> dear";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}