#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z\.\/]+( |%20|\+)(eq|gt)( |%20|\+)[\d\-]+(T[\d:]+(\.[\d]+)?Z|Z( [a-z]+ [\d\-]+Z)?)$"
Local $sString = "aaa.com/activityDateTime eq 2022-05-12Z" & @CRLF & _
"aaa.com/activityDateTime eq 2022-05-12T12:00:00Z" & @CRLF & _
"aaa.com/activityDateTime%20eq%202022-05-12T12:00:00Z" & @CRLF & _
"aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456Z" & @CRLF & _
"aaa.com/activityDateTime gt 2022-03-12Z le 2022-05-12Z" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"aaa.com/activityDateTime eq 2022-05-12" & @CRLF & _
"aaa.com/activityDateTime eq 2022-05-12T12:00:00" & @CRLF & _
"aaa.com/activityDateTime%20eq%202022-05-12T12:00:00" & @CRLF & _
"aaa.com/activityDateTime+eq+2022-05-12T12:00:00.123456" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")